martes, 26 de julio de 2011

Contenido mínimo de una factura

Transcribo de la página de la AEAT (Agencia Estatal Administracion Tributaria)

http://www.aeat.es/wps/portal/Informacion?channel=52a8ce5429761210VgnVCM1000004ef01e0a____&ver=L&site=56d8237c0bc1ff00VgnVCM100000d7005a80____&idioma=es_ES&menu=4&img=5


Contenido de las facturas

Todas las facturas y sus copias deben contener, como mínimo, los siguientes datos o requisitos:
  • Número y, en su caso, serie.
  • Fecha de su expedición.
  • Nombre y apellidos, razón o denominación social completa, tanto del obligado a expedir factura como del destinatario de las operaciones.
  • Número de identificación fiscal atribuido por la Administración española o, en su caso, por la de otro estado miembro de la Comunidad Europea, con el que ha realizado la operación el obligado a expedir la factura.
  • Domicilio del expedidor y del destinatario. Cuando el destinatario de las operaciones sea una persona física que no actúe como empresario o profesional no será obligatoria la consignación de su domicilio.
  • Descripción de las operaciones consignándose todos los datos necesarios para la determinación de la base imponible del impuesto y su importe, incluyendo el precio unitario sin impuesto de dichas operaciones, así como cualquier descuento o rebaja que no esté incluido en dicho precio unitario.
  • El tipo o tipos impositivos, en su caso, aplicados a las operaciones.
  • La cuota tributaria que, en su caso, se repercuta, que deberá consignarse por separado.
  • La fecha de la operación que se documenta o en la que, en su caso ,se haya recibido el pago anticipado, si es distinta a la de expedición de factura.
En las copias de las facturas, junto a los requisitos anteriores, se indicará su condición de copias.

Normas de estilo genéricas

Presentación de normas de estilo genéricas

https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfMTY2Z2pza3FweHI&hl=es

Manual de Estilo - Curso Pai Torneiros

Manual de Estilo - Curso Pai Torneiros

En el siguiente enlace, se encuentra el manual de estilo consensuado para utilizar durante el curso.

https://docs.google.com/document/d/1N2EH3B45jWFKIC8wa8klpYdNYGouF8Xi2z1pBUU_o6g/edit?hl=es

Trabajo fin de Módulo 2

Aquí os dejo el enunciado del trabajo de fin del módulo 2.

Se os pide la creación por un lado de la estructura de la Base de Datos en formato Access (denominado 2009 - Nombre alumno), creando las tablas, campos y relaciones necesarias para almacenar los datos, aunque no es preciso introducir datos.

Asimismo se os pide que entreguéis un documento de word (denominado 2010 - Nombre alumno) con el contenido de las sentencias SQL para la realización de las búsquedas y la obtención de los listados propuestos en el enunciado. No es preciso la creación de ninguna consulta adicional, como serían las necesarias para la introducción de datos a la Base de Datos o el proceso de compra o venta.

https://docs.google.com/document/d/1B2xQQ9ciAulD-_JrmblPX7S28XwhsV33GV5LGv3bJ00/edit?hl=es

viernes, 22 de julio de 2011

Tamaño texto Access 2007

Incrementar tamaño letras en las ventanas de Microsoft Access 2007
Para incrementar el tamaño de la fuente de los textos en las consultas de Microsoft Access 2007, es preciso pulsar el Botón de Office, y seleccionar la opción Opciones de Access.


Para modificar el texto de las consultas tanto en el diseñador como mediante SQL, elegir la opción Tamaño, dentro de Diseño de la consulta dentro del apartado diseñadores de Objetos.




Para cambiar el tamaño de la fuente en las tablas, es preciso ir a Tamaño, dentro de la opción Fuente Predeterminada dentro del apartado Hoja de Datos.







Ejemplos Pseudocódigo 2/2

Mas ejemplos de pseudocódigo realizados en clase a día 22-07-2011
Aqui os dejo otra tanda de ejercicios de peudocódigo. Son los mismos que están en la presentación:
https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfMTUwZ2ZydGNmYzc&hl=es

Leer de teclado dos números enteros (no hace falta comprobarlo), y mostrar por pantalla si son iguales o no.
Ej: Nos dan el 2 y el 2 y mostramos "Los valores son iguales".
Ej: Nos dan el 2 y el 3 y mostramos "Los valores son diferentes".
INICIO
VALOR1=0; VALOR2=0;
LEER VALOR1, VALOR2
SI VALOR1 = VALOR2
MOSTRAR "Los valores que usted ha introducido son iguales"
SINO
MOSTRAR "Los valores que usted ha introducido son distintos"
FIN SI
FIN


SELECT CASE, SWITCH
HACER EN CASO
EN CASO VARIABLE = VALOR1:
INSTRUCCIÓN(ES) 1
EN CASO VARIABLE = VALOR2:
INSTRUCCIÓN(ES) 2
EN CASO VARIABLE = VALOR3:
INSTRUCCIÓN(ES) 3
[ SEA OTRO VALOR:
INSTRUCCIÓN(ES) N ]


SELECT CASE, SWITCH
Pedir un número por teclado entre 1 y 3 ambos inclusive, mostrar un mensaje indicando en texto el número metido, o un mensaje de advertencia en caso de que el valor introducido no sea correcto.
INICIO
numero=0;
MOSTRAR "Dame un número entre 1 y 3"
LEER numero
HACER EN CASO
EN CASO numero= 1:
MOSTRAR "Has escrito uno"
EN CASO numero= 2:
MOSTRAR "Has escrito dos"
EN CASO numero= 3:
MOSTRAR "Has escrito tres"
SEA OTRO VALOR:
MOSTRAR "El valor introducido no es válido"
FIN


SELECT CASE, SWITCH
Pedir por teclado el número de mes y responder por pantalla el nombre del mes y el número de días que tiene (realizar para los 4 primeros meses).
INICIO
numero_mes=0;
MOSTRAR "Dame el número del mes"
LEER numero_mes
HACER EN CASO
EN CASO numero_mes= 1:
MOSTRAR "El mes es Enero y tiene 31 días."
EN CASO numero_mes= 2:
MOSTRAR "El mes es Febrero y tiene 28 o 29 días."
EN CASO numero_mes= 3:
MOSTRAR "El mes es Marzo y tiene 31 días."
EN CASO numero_mes= 4:
MOSTRAR "El mes es Abril y tiene 30 días."
SEA OTRO VALOR:
MOSTRAR "Has introducido un dato no válido."
FIN

INICIO
numero_mes=0;
MOSTRAR "Dame el número del mes"
LEER numero_mes
HACER EN CASO
EN CASO numero_mes= 1:
MOSTRAR "El mes es Enero y tiene 31 días."
EN CASO numero_mes= 2:
MOSTRAR "El mes es Febrero y tiene 28 o 29 días."
EN CASO numero_mes= 3:
MOSTRAR "El mes es Marzo y tiene 31 días."
EN CASO numero_mes= 4:
MOSTRAR "El mes es Abril y tiene 30 días."
EN CASO numero_mes= 5:
MOSTRAR "El mes es Mayo y tiene 31 días."
EN CASO numero_mes= 6:
MOSTRAR "El mes es Junio y tiene 30 días."
EN CASO numero_mes= 7:
MOSTRAR "El mes es Julio y tiene 31 días."
EN CASO numero_mes= 8:
MOSTRAR "El mes es Agosto y tiene 31 días."
EN CASO numero_mes= 9:
MOSTRAR "El mes es Septiembre y tiene 30 días."
EN CASO numero_mes= 10:
MOSTRAR "El mes es Octubre y tiene 31 días."
EN CASO numero_mes= 11:
MOSTRAR "El mes es Noviembre y tiene 30 días."
EN CASO numero_mes= 12:
MOSTRAR "El mes es Diciembre y tiene 31 días."
SEA OTRO VALOR:
MOSTRAR "El número introducido no se corresponde con ningún mes."
FIN


MIENTRAS, WHILE
FORMATO:
MIENTRAS (condición) HACER
Instrucciones
FIN MIENTRAS
Permite repetir las instrucciones mientras que se cumpla la condición.
El bucle contrario sería el HASTA que se ejecutaría hasta que se cumpla la condición.


MIENTRAS, WHILE
Solicitar un número entero mayor que cero (no es necesario comprobarlo) y mostrar en pantalla todos los números desde cero hasta el número
indicado
INICIO
valor_limite=0;contador=0;
MOSTRAR "Hasta que número quieres que cuente."
LEER valor_limite
MIENTRAS (contador <= valor_limite) HACER
MOSTRAR contador
contador = contador + 1
FIN MIENTRAS
FIN


MIENTRAS, WHILE
Solicitar un número entero mayor que cero (no es necesario comprobarlo) y mostrar en pantalla el sumatorio, (la suma de los valores) desde 1 hasta el número indicado:
Ej: numero 3 -> resultado = 1 + 2 + 3 = 6
INICIO
valor_limite=0;contador=0;sumatorio=0;
MOSTRAR "Hasta que número quieres que realice el sumatorio."
LEER valor_limite
MIENTRAS (contador <= valor_limite) HACER
sumatorio = sumatorio + contador
contador = contador + 1
FIN MIENTRAS
MOSTRAR sumatorio
FIN


REPETIR MIENTRAS, DO WHILE
MIENTRAS, WHILE
FORMATO:
REPETIR
Instrucciones
MIENTRAS (condicion)
Permite repetir las instrucciones mientras que se cumpla la condición.
A diferencia del WHILE siempre se ejecuta al menos una vez.
El bucle contrario sería el REPETIR HASTA que se ejecutaría hasta que se cumpla la condición.


REPETIR MIENTRAS, DO WHILE
Ej:
Solicitar un número por pantalla y realizar sumatorio desde 0 hasta el número, mostrando mensaje en caso contrario.
INICIO
valor_limite=0; suma=0 ;contador=0; mensaje="La suma parcial es: "
MOSTRAR "Hasta que número quieres que SUME."
LEER valor_limite
SI valor_limite<=0 mensaje = "Error valor no admitido: "
REPETIR
MOSTRAR mensaje + suma
suma = suma + contador
contador = contador + 1
MIENTRAS (contador <= valor_limite)
MOSTRAR "El resultado es: ", suma
FIN


PARA, FOR
Permite que un conjunto de instrucciones se ejecuten un numero determinados de veces.
Ejecuta el bucle iniciando el contador en val1, hasta que llegue a val2, y con el incremento que indique val3 (si se omite val3, se asume un incremento de 1)
FORMATO:
PARA var = val1 HASTA val2 [ SUMANDO VAL3 ]
instrucciones
FIN PARA


PARA, FOR
Solicitar un valor positivo mayor que 1 por pantalla, y listar todos los números desde 1 hasta el indicado utilizando el bucle PARA.
INICIO
valor_limite = 0
MOSTRAR "Dame el valor hasta el que quieres que cuente: "
LEER valor_limite
PARA var = 1 HASTA valor_limite
MOSTRAR var
FIN PARA
FIN


PARA, FOR
Solicitar un valor positivo mayor que 1 por pantalla, y listar todos los números de tres en tres desde 1 hasta el indicado utilizando el bucle PARA.
INICIO
valor_limite = 0
MOSTRAR "Dame el valor hasta el que quieres que cuente: "
LEER valor_limite
PARA var = 1 HASTA valor_limite SUMANDO 3
MOSTRAR var
FIN PARA
FIN


PARA, FOR
Solicitar un valor positivo mayor que 1 por pantalla, y listar de manera descendiente los números de tres en tres.
INICIO
valor_limite = 0
MOSTRAR "Dame el valor desde el que quieres que cuente: "
LEER valor_limite
PARA var = valor_limite HASTA 1 SUMANDO -3
MOSTRAR var
FIN PARA
FIN

EJERCICIOS
PSEUDOCÓDIGO

Ejercicios
Ejercicio 2007 - Nombre alumno
a) Solicitar un número por pantalla (entero y positivo, no hace falta comprobarlo) y listar por pantalla los números impares desde el solicitado hasta el 1.
b) Calcular el factorial de un número solicitado por pantalla (entero y positivo, no hace falta comprobarlo).

Ejercicios
Ejercicio 2008 - Nombre alumno
a) Leer un número (entero y positivo, no hace falta comprobarlo) y determinar si es divisible por 3 y por 2 al mismo tiempo.
b) Leer un número (entero y positivo, no hace falta comprobarlo) y determinar si es divisible por 5, 4, 3, 2 y 1 al mismo tiempo.
c) Dado un año, mostrar si es bisiesto.

Ejercicios
c) Dado un año, mostrar si es bisiesto.
INICIO
ANHO = 0; RES004=0; RES100=0; RES400=0;
LEER ANHO
RES004 = RESTO (ANHO / 4)
RES100 = RESTO (ANHO / 100)
RES400 = RESTO (ANHO / 400)
SI RES004 = 0 Y RES100 > 0 Y RES400 > 0
MOSTRAR "O ano e bisiesto."
FINSI
SI RES004 > 0
MOSTRAR "O ano NON e bisiesto."
FINSI
SI RES004 = 0 Y RES100 = 0 Y RES400 > 0
MOSTRAR "O ano NON e bisiesto."
FINSI
SI RES004 = 0 Y RES100 = 0 Y RES400 = 0
MOSTRAR "O ano e bisiesto."
FINSI
FIN

Ejercicios
c) Dado un año, mostrar si es bisiesto.
INICIO
ANHO = 0; RES004=0; RES100=0; RES400=0;
LEER ANHO
RES004 = RESTO (ANHO / 4)
RES100 = RESTO (ANHO / 100)
RES400 = RESTO (ANHO / 400)
SI RES004>0 O (RES004 =0 Y RES100=0 Y RES400>0)
MOSTRAR "No bisiesto"
SINO
MOSTRAR "Si bisiesto"
FINSI
FIN

Ejercicios
c) Dado un año, mostrar si es bisiesto.
INICIO
ANHO = 0; RES004=0; RES100=0; RES400=0;
LEER ANHO
RES004 = RESTO (ANHO / 4)
RES100 = RESTO (ANHO / 100)
RES400 = RESTO (ANHO / 400)
SI (RES004 =0 Y RES100=0 Y RES400 = 0 O (RES004 =0 Y RES100>0 Y RES400>0)
MOSTRAR "SI bisiesto"
SINO
MOSTRAR "NO bisiesto"
FINSI
FIN

Ejercicios
c) Dado un año, mostrar si es bisiesto.
INICIO
ANHO = 0; RES004=0; RES100=0; RES400=0;
LEER ANHO
RES004 = RESTO (ANHO / 4)
RES100 = RESTO (ANHO / 100)
RES400 = RESTO (ANHO / 400)
SI (RES004 =0 Y RES100=0 Y RES400 = 0)
MOSTRAR "SI bisiesto"
SINO
SI (RES004 =0 Y RES100>0 Y RES400>0)
MOSTRAR "SI bisiesto"
SINO
MOSTRAR "NO bisiesto"
FINSI
FINSI
FIN


d) Esta compañía precisa de una administrativa. A las candidatas se les realizan unas reguntas:
- ¿Está soltera (1) o casada (2), otro (0)?
- ¿Cantidad de hijos que tiene? Si no tiene indicar 0
- ¿Posee algún título técnico S/N?
- ¿Cuantos años tiene?
Serán preseleccionadas las que cumplan los siguientes requisitos:
. Mujeres solteras que estén en posesión de un título técnico, sin hijos y menores de 25 años.
. Mujeres casadas con edad superior a 40 años y con hijos.
Tras introducir los datos indicar a la aspirante si está preseleccionada o no.


e) Solicitar por teclado un número entero entre 1 y 2000, y sacarlo por pantalla en números romanos.
1000 M
500 D
100 C
50 L
10 X
5 V
1 I


INICIO
DATO=0; UNIDADES=0; DECENAS=0; CENTENAS=0; MILLARES=0;
MOSTRAR "Dime que número quieres que pase a ROMANOS"
LEER DATO
MILLARES = PARTENT (DATO / 1000)
DATO = RESTO (DATO / 1000)
CENTENAS = PARTENT (DATO / 100)
DATO = RESTO (DATO / 100)
DECENAS= PARTENT (DATO / 10)
UNIDADES= RESTO (DATO / 10)
HACER EN CASO
EN CASO MILLARES = 1: MOSTRAR "M"
EN CASO MILLARES = 2: MOSTRAR "MM"
FIN EN CASO
HACER EN CASO
EN CASO CENTENAS = 1: MOSTRAR "C"
EN CASO CENTENAS = 2: MOSTRAR "CC"
EN CASO CENTENAS = 3: MOSTRAR "CCC"
EN CASO CENTENAS = 4: MOSTRAR "CD"
EN CASO CENTENAS = 5: MOSTRAR "D"
EN CASO CENTENAS = 6: MOSTRAR "DC"
EN CASO CENTENAS = 7: MOSTRAR "DCC"
EN CASO CENTENAS = 8: MOSTRAR "DCCC"
EN CASO CENTENAS = 9: MOSTRAR "CM"
FIN EN CASO


HACER EN CASO
EN CASO DECENAS = 1: MOSTRAR "X"
EN CASO DECENAS = 2: MOSTRAR "XX"
EN CASO DECENAS = 3: MOSTRAR "XXX"
EN CASO DECENAS = 4: MOSTRAR "XL"
EN CASO DECENAS = 5: MOSTRAR "L"
EN CASO DECENAS = 6: MOSTRAR "LX"
EN CASO DECENAS = 7: MOSTRAR "LXX"
EN CASO DECENAS = 8: MOSTRAR "LXXX"
EN CASO DECENAS = 9: MOSTRAR "XC"
FIN EN CASO
HACER EN CASO
EN CASO UNIDADES = 1: MOSTRAR "X"
EN CASO UNIDADES = 2: MOSTRAR "XX"
EN CASO UNIDADES = 3: MOSTRAR "XXX"
EN CASO UNIDADES = 4: MOSTRAR "XL"
EN CASO UNIDADES = 5: MOSTRAR "L"
EN CASO UNIDADES = 6: MOSTRAR "LX"
EN CASO UNIDADES = 7: MOSTRAR "LXX"
EN CASO UNIDADES = 8: MOSTRAR "LXXX"
EN CASO UNIDADES = 9: MOSTRAR "XC"
FIN EN CASO


Tabla de los valores de las veriables en el pseudocódigo de números romanos
DATO MILLARES CENTENAS DECENAS UNIDADES
0 0 0 0 0
1935 0 0 0 0
1935 1 0 0 0
935 1 0 0 0
935 1 9 0 0
35 1 9 0 0
35 1 9 3 0
35 1 9 3 5


f) A partir de la nota numérica imprimir la nota en texto.
Nota Numérica Nota Texto
>= 9 <= 10 Sobresaliente
>= 7 < 9 Notable
>= 6 < 7 Bien
>= 5 < 6 Suficiente
<5 Insuficiente


f) A partir de la nota numérica imprimir la nota en texto.
INICIO
NOTA = 0,0;
MOSTRAR "Introduce la nota".
LEER NOTA
SI NOTA < 5 MOSTRAR "Insuficiente"
SI (NOTA >= 5 Y NOTA < 6) MOSTRAR "Suficiente"
SI (NOTA >= 6 Y NOTA < 7) MOSTRAR "Bien"
SI (NOTA >= 7 Y NOTA < 9) MOSTRAR "Notable"
SI (NOTA >= 9 Y NOTA < 10) MOSTRAR "Sobresaliente"
FIN


g) Calcular el área de un triángulo a partir de la base y la altura.
AREA = (BASE * ALTURA) / 2
INICIO
BASE = 0,0; ALTURA = 0,0; AREA = 0,0;
MOSTRAR "Dime la Base"
LEER BASE
MOSTRAR "Dime la Altura"
LEER ALTURA
AREA = (BASE * ALTURA) / 2
MOSTRAR "El área es: " AREA
FIN


h) Calcular el área y el perímetro de un circulo dado su diámetro.
PERIMETRO = PI * (2 * R) = PI * D
AREA = PI * R * R = PI * (D/2) * (D/2)
INICIO
PI=3,14; DIAMETRO = 0,0;
MOSTRAR "Dime el diametro"
LEER DIAMETRO
MOSTRAR "El perimetro es " PI * DIAMETRO
MOSTRAR "El area es " PI * (DIAMETRO /2) * (DIAMETRO /2)
FIN


i) Transformar la velocidad de un vehículo dada en Km/h a m/seg.
INICIO
VELOCIDAD = 0,0;
MOSTRAR "Indicame la velocidad en Km/h"
LEER VELOCIDAD
MOSTRAR "Velocidad en m/s " VELOCIDAD / 3,6
FIN


J) Indicar a partir del número de días a partir del 01-01-2011, inclusive. Cuántos años, meses, semanas y días constituyen el número de días.
Ejemplo: 1 días -> 0 años, 0 meses, 0 semanas, 1 días
40 días -> 0 años, 1 mes (enero), 1 semana, 2 días
335 días -> 0 años, 11 messes, 0 semanas, 1 días (01-02-2011)
1100 días -> 3 años, 0 messes, 0 semanas, 4 días (04-01-2014)
Asumiremos que tenemos dos funciones:
BISIESTO (NUMERO_ANO)
devuelve 0 si no es bisiesto y 1 si lo es.
DIASMES (NUMERO_MES, ANO)
devuelve el número de días que tiene un mes, diferenciando en febrero si es bisiesto o no.

INICIO
num_dias = 0; contador_meses = 1; contador_dias = 0; ano =
2011; anos = 0; meses = 0; semanas = 0; dias = 0;
MOSTRAR "Dime el número de días."
LEER num_dias
MIENTRAS (num_dias - contador_dias >= 366)
SI BISIESTO (ano)
contador_dias = contador_dias + 366
anos = anos + 1
ano = ano + 1
SINO
contador_dias = contador_dias + 365
anos = anos + 1
ano = ano + 1
FIN SI
FIN MIENTRAS

SI num_dias - contador_dias = 365
contador_dias = contador_dias + 365
anos = anos + 1
ano = ano + 1
FINSI
MIENTRAS (num_dias - contador_dias) >= DIASMES (contador_meses, ano)
contador_dias = contador_dias + DIASMES (contador_meses, ano)
contador_meses = contador_meses +1
FIN MIENTRAS
semanas = PARTENT (num_dias - contador_dias) / 7
dias = RESTO (num_dias - contador_dias) / 7
MOSTRAR anos
MOSTRAR contador_meses -1
MOSTRAR semanas
MOSTRAR dias
FIN


k) Dado un numero entero positivo mayor que 1, indicar si es primo o no.
Nota: Número primo es aquel que solo es divisible entre él mismo y 1.
Ej:
3 divisible solo entre 3 y 1 -> es primo.
4 divisible entre 4, 2 y 1 -> no es primo.


k) Dado un numero entero positivo mayor que 1, indicar si es primo o no.
INICIO
VALOR_ORIGINAL = 0; INDICE = 0; CONTADOR = 0;
MOSTRAR "Dame un valor y te diré si es primo: "
LEER VALOR_ORIGINAL
INDICE = VALOR_ORIGINAL
MIENTRAS INDICE > 0
SI RESTO (VALOR_ORIGINAL / INDICE) = 0 CONTADOR = CONTADOR + 1
INDICE = INDICE -1
FIN MIENTRAS
SI CONTADOR > 2
MOSTRAR "EL NUMERO NO ES PRIMO"
SINO
MOSTRAR "EL NUMERO ES PRIMO"
FINSI
FIN

jueves, 21 de julio de 2011

Ejemplo de Base de datos de vehículos

Base de datos de vehículos
Incluye Clientes, Vendedores, Ventas, Modelos de vehículos, y vehículos.
Se listan los posibles campos, y se muestran las relacioens creadas en Access tal y como se vió en clase.


https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfMTU3ZDdtMnJmY3o&hl=es

viernes, 15 de julio de 2011

Google+

Google+ arranca a todo tren: Más de 1.000 millones de ítems compartidos cada día
http://feedproxy.google.com/~r/EngadgetSpanish/~3/dPgG-WYiz4M/

Open Office

IBM cede el código de Lotus Symphony a Apache para OpenOffice


http://feedproxy.google.com/~r/Muycomputer/~3/jKsbqh95vs4/story01.htm

Inteligencia Artificial

Una Inteligencia Artificial que aprende a jugar al jueto Civilization tras leerse el manual
http://hipertextual.feedsportal.com/c/33160/f/538992/s/16ab5455/l/0Lgizmologia0N0C20A110C0A70Cia0Eaprende0Ea0Ejugar0Eciv/story01.htm

Presentación SQL

Presentación SQL
https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfMTQ4N3Z2dzYyY3Y&hl=es

jueves, 14 de julio de 2011

Ejemplos Pseudocódigo 1/2


Ejemplos Pseudocódigo (14-07-2011)


Leer de teclado un número decimal, y mostrar por pantalla la
parte entera.
INICIO
NUMERO=0,0; PE=0;
LEER A
PE = PARTEENTERA NUMERO
MOSTRAR "La parte entera del número introducido es: " PE
FIN






Leer de teclado un número decimal, y mostrar por pantalla la
parte entera y la parte decimal por separado.
INICIO
NUMERO = 0,0; PE=0; PD=0,0;
LEER NUMERO
PE = PARTEENTERA NUMERO
PD = PARTEDECIMAL NUMERO
MOSTRAR "La parte entera es: " PE
MOSTRAR "La parte decimal es: " PD
FIN






Leer de teclado dos números enteros mayores de cero (no hace falta
comprobarlo), y mostrar un mensaje por pantalla indicando si son
divisibles o no.
INICIO
A=0; B=0; RES=0;
LEER A, B
RES = RESTO A / B
SI RES > 0
MOSTRAR "Los dos números no son divisibles"
SINO
MOSTRAR "Los dos números son divisibles"
FIN SI
FIN






Leer de teclado dos números enteros mayores de cero (no hace falta
comprobarlo), y mostrar un mensaje por pantalla indicando si son
divisibles o no.
INICIO
A=0; B=0; RES=0; DIVISIBLE="";
LEER A, B
RES = RESTO A / B
SI RES > 0
DIVISIBLE = "Los dos números no son divisibles"
SINO
DIVISIBLE = "Los dos números son divisibles"
FIN SI
MOSTRAR DIVISIBLE
FIN






Ejercicio 2006 - Nombre alumno
Leer de teclado enteros mayores de cero (no hace falta comprobarlo), y
mostrar un mensaje por pantalla indicando si es par.
INICIO
A=0; RES=0;
LEER A
RES = RESTO A / 2
SI RES > 0
MOSTRAR "El número es impar"
SINO
MOSTRAR "El número es par"
FIN SI
FIN






Leer de teclado un número entero mayores de cero (no hace falta
comprobarlo), y mostrar por pantalla el siguiente número.
Ej: Nos dan el 8 y mostramos el 9.
INICIO
A=0;
LEER A
A = A + 1
MOSTRAR "El siguiente número es: " A
FIN






Leer de teclado un número entero (no hace falta comprobarlo), y
mostrar por pantalla si es positivo o negativo.
Se asume que el cero es positivo.
Ej: Nos dan el -1 y mostramos "El valor es negativo".
INICIO
A=0;
LEER A
SI A < 0
MOSTRAR "El número introducido es NEGATIVO"
SINO
MOSTRAR "El número introducido es POSITIVO"
FIN SI
FIN






Leer de teclado un número entero (no hace falta comprobarlo), y
mostrar por pantalla si es positivo o negativo.
Se asume que el cero es positivo.
Ej: Nos dan el -1 y mostramos "El valor es negativo".
INICIO
A=0;
LEER A
SI A < 0
MOSTRAR "El número introducido es NEGATIVO"
FIN SI
SI A >= 0
MOSTRAR "El número introducido es POSITIVO"
FIN SI
FIN






Leer de teclado un número entero (no hace falta comprobarlo), y mostrar por pantalla
si es positivo, negativo o NULO. Se asume que el cero es NULO.
Ej: Nos dan el -1 y mostramos "El valor es negativo".
INICIO
A=0;
LEER A
SI A < 0
MOSTRAR "El número introducido es NEGATIVO"
FIN SI
SI A > 0
MOSTRAR "El número introducido es POSITIVO"
FIN SI
SI A = 0
MOSTRAR "El número introducido es NULO"
FIN SI
FIN


Leer de teclado un número entero (no hace falta comprobarlo), y mostrar por pantalla si es positivo, negativo o NULO. Se asume que el cero es NULO.


Ej: Nos dan el -1 y mostramos "El valor es negativo".


INICIO
A=0; 
LEER A
SI A < 0
    MOSTRAR "El número introducido es NEGATIVO"
SINO
    SI A = 0
        MOSTRAR "El número introducido es NULO"       
    SINO
        MOSTRAR "El número introducido es POSITIVO" 
    FIN SI   
FIN SI
FIN



Exemplos Pseudocódigo vistos na clase

Exemplos Pseudocódigo vistos na clase
https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfMTUwZ2ZydGNmYzc&hl=es

jueves, 7 de julio de 2011

FIN DE MODULO ARQUITECTURA DE ORDENADORES

Felicidades a todos por el trabajo realizado durante este módulo.

Explicación uso del FOR con la opcion token

Os dejo un enlace en el que se explica como usar el bucle for en MSDOS, utilizando la opción token y delims, para coger partes de un fichero.

http://www.palomatica.info/juckar/microsoft/msdos/bat/for.html

Se podría usar para quedarse solo con el nombre del fichero, eliminando la extensión.
Con el siguiente código se conseguiría que el listado de amigos del programa de estantería no mostrase las extensiones de los archivos.


@ECHO OFF
REM ELIMINAMOS ECOS DE PANTALLA

REM LIMPIAMOS PANTALLA
CLS

CD PRESTAMOS

if exist .\..\listados\amigos.txt del .\..\listados\amigos.txt

REM LISTAR AMIGOS QUE TIENEN LIBROS PRESTADOS USANDO FOR
ECHO ------------------------------------------------------
ECHO LISTADO DE  AMIGOS CON FOR
ECHO ------------------------------------------------------
FOR %%i IN (*.PRE) DO ECHO %%i >> .\..\listados\amigos.txt

for /F "tokens=1 delims=." %%i in (.\..\listados\amigos.txt) do echo %%i

CD..
PAUSE > NUL

Estantería (Código y pseudocódigo)

Presentación con el código del programa por lotes de la estantería, y el pseudocódigo correspondiente.

https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfMTI0cmR0a3BnZ20&hl=es

miércoles, 6 de julio de 2011

Temario curso Programador de Aplicaciones Informáticas

Aquí os dejo el temario oficial del curso Programador de Aplicaciones Informáticas

https://docs.google.com/viewer?a=v&pid=explorer&chrome=true&srcid=0B6WlzM8W-gAEZjQ5NzY3ZDItNGQ0MS00YmFmLWJmN2YtMWMxYzVhMWQ5MzY1&hl=es

Creación de organigramas vía web

Enlace facilitado por Esteban que permite crear organigramas via web.

http://www.gliffy.com/

Lanzamiento del SDK para programar en Kinect

Aquí os dejo un enlace a una web en la que se explica como programar en kinect

 http://www.desarrolloweb.com/actualidad/sdk-kinect-lanzamiento-5401.html

Ejemplos de programacion Microsoft Kinect

Enlace a web con hacks de Kinect que se vieron en clase
http://kinecthacks.net

Lenguajes de programación (Diapositivas Ensambladores, Compiladores, Interpretes, etc.)

Programador de Aplicaciones Informáticas
Módulo 1
ARQUITECTURA DE ORDENADORES
Lenguajes de programación (Diapositivas Ensambladores, Compiladores, Interpretes, etc.)

Diapositivas de Lenguajes de Programación (Ensambladores, Compiladores, Interpretes, etc.)
https://docs.google.com/present/edit?id=0AaWlzM8W-gAEZGY0ZHM1cWNfOGNtaGQyaGQ2&hl=es

viernes, 1 de julio de 2011

Archivos de proceso por lotes de MSDOS


Como hemos visto en clase son secuencias de comandos MSDOS agrupados en un fichero de texto, que se puede crear con cualquier procesador de textos, EDIT, NOTEPAD, etc.


También son llamados archivos batch.


Los comandos se ejecutan de forma secuencial permitiendo automatizar tareas.


Es preciso tener cuidado con los caracteres que no sean del estandar ascii, pues el MSDOS interpreta ascii y el bloc de notas y otros editores de windows interpretan Ansi.


A continuación un enlace con información, y en los siguientes posts los ejemplos realizados en clase.
http://es.wikipedia.org/wiki/Batch
Related Posts Plugin for WordPress, Blogger...